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Getting Started with Model
Link Products

• “Product Overview” on page 1-2

• “Basic Workflow” on page 1-3

• “Tutorial: Verifying Code from a Simple Model” on page 1-5



1 Getting Started with Model Link Products

Product Overview

In this section...

“Polyspace® Model Link™ SL” on page 1-2

“Polyspace® Model Link™ TL” on page 1-2

Polyspace Model Link SL
Polyspace® Model Link™ SL extends Polyspace Client™ for C/C++ and
Polyspace Server™ for C/C++ with tools that let you trace Polyspace results
from generated C code directly to your Simulink® model. As a result, you can
identify which parts of the model are reliable, and correct design problems
that will cause run-time errors in the code. With Polyspace Model Link
SL, you work in the Simulink environment to verify C code generated
by Embedded Coder™ software. You can verify a mix of generated and
hand-written code before it is compiled.

Polyspace Model Link TL
Polyspace Model Link TL extends Polyspace Client for C/C++ and Polyspace
Server for C/C++ with tools that let you verify C code generated by
TargetLink® and trace Polyspace results from the generated C code to your
model. As a result, you can identify which parts of the model are reliable, and
correct design problems that will cause run-time errors in the code. With
Polyspace Model Link TL software, you work in the Simulink environment to
verify C code generated by TargetLink. You can verify a mix of generated and
hand-written code before it is compiled.
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Basic Workflow

Basic Workflow
With Embedded Coder or dSPACE® TargetLink software, you can generate
C code from models in the Simulink Model-Based Design environment.
Using Polyspace Model Link SL and Polyspace Model Link TL software, you
can apply Polyspace verification to the generated code within the Simulink
environment. The software detects run-time errors in the generated code and
helps you to locate and fix model faults.

Note The documentation describes steps for the Polyspace Model Link SL
product, but states differences between the Polyspace Model Link SL and
Polyspace Model Link TL products where appropriate.

The workflow for using Polyspace Model Link software is:

1 Configure your Simulink model and generate code. See “Overview of Model
Configuration for Code Generation and Verification” on page 2-2.

2 Configure Polyspace verification options. See “Overview of Polyspace
Configuration” on page 3-2

Note After generating code, you can run a verification without manual
configuration. By default, Polyspace automatically creates a project and
extracts required information from your model. However, you can also
customize your verification. See “Configuring Polyspace Verification
Options” on page 3-11.

3 Run Polyspace verification. See:

• “Running Verification with Polyspace® Model Link™ SL Software” on
page 4-2

• “Running Verification with Polyspace® Model Link™ TL Software” on
page 4-5

.
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1 Getting Started with Model Link Products

4 View results, analyze errors, locate and fix model faults. See “Viewing
Results in Polyspace Verification Environment” on page 5-2.

The software allows direct navigation from a run-time error in the
generated code to the corresponding Simulink block or Stateflow® chart in
the Simulink model. See “Identifying Errors in Simulink Models” on page
5-5.
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Tutorial: Verifying Code from a Simple Model

Tutorial: Verifying Code from a Simple Model

In this section...

“Create Simulink Model and Generate Code” on page 1-5

“Run Polyspace Verification” on page 1-11

“View Results in Polyspace Verification Environment” on page 1-12

“Trace Error to Simulink Model” on page 1-14

“Specify Signal Ranges” on page 1-15

“Verify Updated Model” on page 1-17

Create Simulink Model and Generate Code
To create a simple Simulink model and generate code:

1 Open MATLAB®, then start Simulink software.

2 Construct the following model.
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1 Getting Started with Model Link Products

3 Select File > Save. Then name the model my_first_code.

4 Select View > Model Explorer.

The Model Explorer opens.

5 Select my_first_code > Configuration, in the Model Hierarchy.

6 Select Code Generation in the Configuration view.

The Code Generation configuration parameters open.

7 Select the General tab.

Set the System target file to ert.tlc (Embedded Coder).
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Tutorial: Verifying Code from a Simple Model

8 Select the Report tab.

9 Select Create code-generation report, and then select Code-to-model
Navigation.
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1 Getting Started with Model Link Products

10 Select the Templates tab.
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Tutorial: Verifying Code from a Simple Model

11 In the Custom templates section, clear Generate an example main
program.

12 Select the Interface tab.
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1 Getting Started with Model Link Products

13 In the Code interface section, select suppress error status in real-time
model data structure.

14 Click Apply in the lower-right corner of the window.

15 In the Configuration Preferences, select Solver.

The Solver configuration parameters appear.
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Tutorial: Verifying Code from a Simple Model

16 In the Solver options section, set the solver Type to Fixed-step. Then, set
the Solver to discrete (no continuous states).

17 Click Apply.

18 From the Simulink model window, select Tools > Code
Generation > Build Model to generate code.

19 Save your Simulink model.

Run Polyspace Verification
To start the Polyspace verification:

1 From the Simulink model window, select Tools > Polyspace > Polyspace
for Embedded Coder > Verify Generated Code.

The verification starts, and you see messages in the MATLAB Command
Window.
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1 Getting Started with Model Link Products

### Starting Polyspace verification for Embedded Coder

### Creating results folder C:\PolySpace_Results\results_my_first_code

for system my_first_code

### Checking Polyspace Model-Link Configuration:

### Parameters used for code verification:

System : my_first_code

Results Folder : C:\PolySpace_Results\results_my_first_code

Additional Files : 0

Remote : 0

Model Reference Depth : Current model only

Model by Model : 0

DRS input mode : DesignMinMax

DRS parameter mode : None

DRS output mode : None

### Writing DRS table in C:\PolySpace_Results\results_my_first_code\my_first_code_drs.txt

### Writing generated source files in C:\PolySpace_Results\results_my_first_code

2 Follow the progress of the verification in the MATLAB Command window.

Note Verification of this model takes about a minute. A 3,000 block model
will take approximately one hour to verify, or about 15 minutes for each 2,000
lines of generated code.

View Results in Polyspace Verification Environment
When the verification is complete, you can view the results using the Results
Manager perspective of the Polyspace verification environment.

To view your results:

1 From the Simulink model window, select Tools > Polyspace > Open
Results > For Generated Code.

After a few seconds, the Results Manager perspective of the Polyspace
verification environment opens.
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Tutorial: Verifying Code from a Simple Model

2 On the Results Summary tab, select the orange check.

The Check Details pane shows information about the orange check, and
the Source pane shows the source code containing the orange check.
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1 Getting Started with Model Link Products

This orange check shows a potential overflow issue when multiplying the
signals from the inports In1 and In2. Polyspace software assumes that
the signal values are full range, and the multiplication of the two signals
may result in an overflow.

Trace Error to Simulink Model
To fix this overflow issue, you must return to the Simulink model.

To trace the error to your model:

1 Click the blue underlined link (<Root>/Product) immediately before the
check in the Source pane.

The Simulink model opens, highlighting the block with the error.
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Tutorial: Verifying Code from a Simple Model

2 Examine the model. The highlighted block multiplies two full-range
signals, which could result in an overflow.

The verification identified a potential bug. This could be a flaw in either:

• Design — If the model should be robust against the full signal range, it
is a design bug. In this case, you must change the model to accommodate
the full signal range. For example, you could saturate the output of the
previous block, or bound the signal with a Switch block.

• Specifications — If the model is designed to work within specific input
ranges, you can provide these ranges using block parameters or the base
workspace. The verification will then read these ranges from the model,
and the check will turn green.

Specify Signal Ranges
If you constrain the signals in your Simulink model to specified ranges,
Polyspace software automatically applies these constraints during verification
of the generated code. The OVFL check will then be green in the verification
results.

To specify signal ranges using source block parameters:

1-15



1 Getting Started with Model Link Products

1 Double-click the In1 source block in your model.

2 The Source Block Parameters dialog box opens.

3 Select the Signal Attributes tab.

4 Set the Minimum value for the signal to -15.

5 Set the Maximum value for the signal to 15.
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Tutorial: Verifying Code from a Simple Model

6 Click OK.

7 Repeat steps 1–6 for the In2 block.

8 Save your model as my_first_code_bounded.

Verify Updated Model
After changing your model, you must re-generate code and run verification
again.

To regenerate code and relaunch verification:

1 From the Simulink model window, select Tools > Code
Generation > Build Model.

The software generates code for the updated model.

2 Select Tools > Polyspace > Polyspace for Embedded Coder > Verify
Generated Code.

The software verifies the generated code.

3 Select Tools > Polyspace > Open Results.

Verification results open in the Polyspace verification environment.

4 In the Results Manager perspective, select the Results Explorer tab.
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1 Getting Started with Model Link Products

The OVFL check is now green. Polyspace verification shows that no
run-time errors are present in the model.
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2

Configure Model for Code
Verification

• “Overview of Model Configuration for Code Generation and Verification”
on page 2-2

• “Configuring Simulink Model for Code Verification” on page 2-3

• “Recommended Model Settings for Code Verification” on page 2-5

• “Checking Simulink Model Settings” on page 2-7

• “Specifying Signal Ranges” on page 2-9

• “Annotating Blocks to Justify Known Checks or Coding-Rules Violations”
on page 2-14



2 Configure Model for Code Verification

Overview of Model Configuration for Code Generation
and Verification

To facilitate Polyspace code verification and the review of results:

• There are certain settings that you should apply to your model before
generating code. See “Recommended Model Settings for Code Verification”
on page 2-5.

• Polyspace Model Link SL software allows you to check your model
configuration before starting a verification. See “Checking Simulink Model
Settings” on page 2-7

• You can constrain signals in your model to lie within specified ranges. See
“Specifying Signal Ranges” on page 2-9.

• You can highlight blocks that you know contain checks or coding
rule violations. See “Annotating Blocks to Justify Known Checks or
Coding-Rules Violations” on page 2-14.

2-2



Configuring Simulink Model for Code Verification

Configuring Simulink Model for Code Verification
To configure a Simulink model for code generation and verification:

1 Open Model Explorer for your model.

2 In the Configuration for your model, select Code Generation.

The Code Generation configuration parameters open.

3 In the General tab, set the System target file to ert.tlc (Embedded
Coder).

4 In the Report tab, select:

• Create code-generation report

• Code-to-model Navigation.

5 In the Templates tab, clear Generate an example main program.
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2 Configure Model for Code Verification

6 In the Interface tab, select suppress error status in real-time model
data structure.

7 Click Apply to save your changes.

8 In the Configuration for your model, select Solver.

The Solver configuration parameters appear.

9 In the Solver options section, set:

• Type to Fixed-step.

• Solver to discrete (no continuous states).

10 Click Apply to save your changes.

11 Save your model.

2-4



Recommended Model Settings for Code Verification

Recommended Model Settings for Code Verification
For Polyspace verification, you should configure your model with the following
settings before generating code.

Parameter Recommended
value for Polyspace
verification

How you specify value in
Configuration Parameters
dialog box

If you do
not use
recommended
value,
Polyspace
Model Link SL
generates ...

InitFltsAndDblsTo
Zero

'on' Select check box
Optimization > Use
memset to initialize floats
and doubles to 0.0

Warning

InlineParams 'on' Select check box
Optimization > Signals
and Parameters > Inline
parameters

Warning

MatFileLogging 'off' Clear check box Code
Generation > Interface >
MAT-file logging

Warning

Solver 'FixedStepDiscrete' Select discrete (no
continuous states) from
Solver > Solver drop-down
list

Warning

SystemTargetFile 'ert.tlc' Specify ert.tlc (for
Embedded Coder) in Code
Generation > System
target file

Error
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2 Configure Model for Code Verification

Parameter Recommended
value for Polyspace
verification

How you specify value in
Configuration Parameters
dialog box

If you do
not use
recommended
value,
Polyspace
Model Link SL
generates ...

TargetLang 'C' Select C from Code
Generation > Language
drop-down list

Error

ZeroExternalMemory
AtStartup

'off' when
Configuration
Parameters >
Polyspace Model
Link > Data Range
Management >
Output is Global
assert

Clear check box
Optimization > Remove
root level I/O zero
initialization

Warning
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Checking Simulink Model Settings

Checking Simulink Model Settings
With Polyspace Model Link SL software, you can check your model settings
before starting a verification:

1 From the Simulink model window, select Tools > Polyspace > Options.
The Configuration Parameters dialog box opens, displaying the Polyspace
Model Link pane.

2 Click Check configuration. If your model settings are not optimal for
Polyspace verification, the software displays warning messages with
recommendations.

For more information on model settings, see “Recommended Model Settings
for Code Verification” on page 2-5.
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2 Configure Model for Code Verification

Note If you alter your model settings, build the model again to generate
fresh code. If the generated code version does not match your model version,
the software produces warnings when you run a verification.
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Specifying Signal Ranges

Specifying Signal Ranges
If you constrain signals in your Simulink model to lie within specified ranges,
Polyspace software automatically applies these constraints during verification
of the generated code. This can reduce the number of orange checks in your
verification results.

You can specify a range for a model signal by:

• Applying constraints through source block parameters. See “Specifying
Signal Range through Source Block Parameters” on page 2-9.

• Constraining signals through the base workspace. See “Specifying Signal
Range through Base Workspace” on page 2-11.

Note You can also manually define data ranges using the DRS feature in
the Polyspace verification environment. If you manually define a DRS file,
the software automatically appends any signal range information from your
model to the DRS file. However, manually defined DRS information overrides
information generated from the model for all variables.

Specifying Signal Range through Source Block
Parameters
You can specify a signal range by applying constraints to source block
parameters.

Specifying a range through source block parameters is often easier than
creating signal objects in the base workspace, but must be repeated for each
source block. For information on using the base workspace, see “Specifying
Signal Range through Base Workspace” on page 2-11.

To specify a signal range using source block parameters:

1 Double-click the source block in your model, for example, In1.

2 The Source Block Parameters dialog box opens.
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2 Configure Model for Code Verification

3 Select the Signal Attributes tab.

4 Specify the Minimum value for the signal, for example, -15.

5 Specify the Maximum value for the signal, for example, 15.

6 Click OK.
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Specifying Signal Ranges

Specifying Signal Range through Base Workspace
You can specify a signal range by creating signal objects in the MATLAB
workspace. This information is used to initialize each global variable to the
range of valid values, as defined by the min-max information in the workspace.

Note You can also specify a signal range by applying constraints to
individual source block parameters. This method can be easier than creating
signal objects in the base workspace, but must be repeated for each source
block. For more information, see “Specifying Signal Range through Source
Block Parameters” on page 2-9.

To specify an input signal range through the base workspace:

1 Configure the signal to use, for example, the ExportedGlobal storage class:

a Right-click the signal. From the context menu, select Signal Properties.
The Signal Properties dialog box opens.

b In the Signal name field, enter a name, for example, my_entry1.

c Select the Code Generation tab.

d From the Package drop-down menu, select Simulink.

e In the Storage class drop-down menu, select ExportedGlobal.
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2 Configure Model for Code Verification

f Click OK, which applies your changes and closes the dialog box.

Note For information about supported storage classes, see “Data Range
Specification” on page 3-22.

2 Using Model Explorer, specify the signal range:

a Select View > Model Explorer to open Model Explorer.

b In the Model Hierarchy, select Base Workspace.

c Click the Add Simulink signal button to create a signal. Rename this
signal, for example, my_entry1.
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Specifying Signal Ranges

d Set theMinimum value for the signal, for example, to -15.

e Set theMaximum value for the signal, for example, to 15.

f From the Storage class drop-down list, select ExportedGlobal.

g Click Apply.
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2 Configure Model for Code Verification

Annotating Blocks to Justify Known Checks or
Coding-Rules Violations

You can annotate individual blocks in your Simulink model to inform
Polyspace software of known run-time checks or coding-rule violations.
This allows you to highlight and categorize checks identified in previous
verifications, so that you can focus on new checks when reviewing verification
results.

The Polyspace Run-Time Checks perspective displays the information that
you provide with block annotations, and marks the checks as Justified.

To annotate a block:

1 In the Simulink model window, right-click the block you want to annotate.

2 From the context menu, select Polyspace > Annotations > Edit. The
Polyspace Annotation dialog box opens.

3 From the Annotation type drop-down list, select one of the following:
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Annotating Blocks to Justify Known Checks or Coding-Rules Violations

• Check — To indicate run-time error

• MISRA — To indicate coding rule violation

4 If you want to highlight only one check, select Only 1 check and the
relevant run-time check (or MISRA rule) from the Select RTE check
kind (or Select MISRA rule) drop-down list.

If you want to highlight a list of checks, clear Only 1 check. In the Enter
a list of checks (or Enter a list of rule numbers) field, specify the
run-time checks or MISRA rules that you want to highlight.

5 Select a Status to describe how you intend to address the issue:

• Fix

• Improve

• Investigate

• Justify with annotations

• No Action Planned

• Other

• Restart with different options

• Undecided

6 Select a Classification to describe the severity of the issue:

• High

• Medium

• Low

• Not a defect

7 In the Comment field, enter additional information about the check.

8 Click OK. The software adds the Polyspace annotation is to the block.
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Configure Code Verification
Options

• “Overview of Polyspace Configuration” on page 3-2

• “Including Handwritten Code in Verification” on page 3-3

• “Specifying Client or Server Verification” on page 3-5

• “Configuring Data Range Settings” on page 3-6
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• “Creating a Polyspace Configuration File Template” on page 3-14

• “Specifying Header Files for Target Compiler” on page 3-17
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• “Main Generation for Model Verification” on page 3-19

• “Polyspace® Model Link™ SL Considerations” on page 3-21

• “Polyspace® Model Link™ TL Considerations” on page 3-29
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Overview of Polyspace Configuration
You do not have to manually create a Polyspace project or specify Polyspace
options before running a verification for your generated code. By default,
when you start a verification, Polyspace automatically creates a project and
extracts the required information from your model. However, you can modify
or specify additional options for your verification:

• You may incorporate separately created code within the code generated
from your Simulink model. See “Including Handwritten Code in
Verification” on page 3-3.

• By default, the Polyspace verification is contextual and treats tunable
parameters as constants. You can specify a verification that considers
robustness, including tunable parameters that lie within a range of values.
See “Configuring Data Range Settings” on page 3-6.

• You may customize the options for your verification. For example, to specify
the target environment or adjust precision settings. See “Configuring
Polyspace Verification Options” on page 3-11 and “Recommended Polyspace
Options for Verifying Generated Code” on page 3-23.

• You may create specific configurations for batch runs. See “Creating a
Polyspace Configuration File Template” on page 3-14.

• If you want to verify code generated for a 16-bit target processor, you must
specify header files for your 16-bit compiler. See “Specifying Header Files
for Target Compiler” on page 3-17.
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Including Handwritten Code in Verification
Files such as S-function wrappers are, by default, not part of the Polyspace
verification. You can add these files manually. Steps for Polyspace Model
Link SL are shown here.

To add a file to a verification:

1 From the Simulink model window, select Tools > Polyspace > Options.
The Configuration Parameters dialog box opens, displaying the Polyspace
Model Link pane.

2 Select the Enable additional file list check box. Then click Select files.
The Files Selector dialog box opens.

3 Click Add. The Select files to add dialog box opens.

4 Use the Select files to add dialog box to:

• Navigate to the appropriate folder

• Add the required files.
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The software displays the selected files as a list under Additional files
to analyse.

Note To remove a file from the list, select the file and click Remove. To
remove all files from the list, click Remove all.

5 Click OK.

3-4



Specifying Client or Server Verification

Specifying Client or Server Verification
By default, the software runs the code verification on your Polyspace server.
To specify a client verification:

1 From the Simulink model window, select Tools > Polyspace > Options.
The Configuration Parameters dialog box opens, displaying the Polyspace
Model Link pane.

2 Clear the Send to Polyspace server check box.

3 Click Apply.
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Configuring Data Range Settings
There are two approaches to code verification, which can produce results that
are slightly different:

• Contextual Verification— Prove code works under predefined working
conditions. This limits the scope of the verification to specific variable
ranges, and verifies the code within these ranges.

• Robustness Verification — Prove code works under all conditions,
including “abnormal” conditions for which the code was not designed. This
can be thought of as “worst case” verification.

For more information, see:

• “Choosing Robustness or Contextual Verification” in the Polyspace Products
for C/C++ User’s Guide.

• Data Range Specification — Model Link SL

• Data Range Specification — Model Link TL

Note The software supports data range management only with Simulink
Version 7.4 (R2009b) or later.

Polyspace Model Link SL allows you to run either contextual or robustness
verification by the way you specify data ranges for model inputs, outputs, and
tunable parameters within the model.
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To specify data range settings for your model:

1 From the Simulink model window, select Tools > Polyspace > Options.
The Configuration Parameters dialog box opens, displaying the Polyspace
Model Link pane.

2 In the Data Range Management section, specify how you want the
verification to treat:

a Input — Select one of the following:

• Use specified minimum and maximum values (Default) — Apply
data ranges defined in blocks or base workspace to increase the
precision of the verification. See “Specifying Signal Ranges” on page
2-9.

• Unbounded inputs — Assume all inputs are full-range values
(min...max)

b Tunable parameters — Select one of the following:

• Use calibration data (Default) — Use value of constant parameter
specified in code.

• Use specified minimum and maximum values— Use a parameter
range defined in the block or base workspace. See “Specifying Signal
Ranges” on page 2-9. If no range defined, use full range (min...max).

c Output — Select one of the following:

• No verification (Default) — No assertion ranges on outputs.

• Verify outputs are within minimum and maximum values— Use
assertion ranges on outputs.

Note This mode is incompatible with the Automatic Orange Tester.

In general, you should use the following combinations:

• To maximize verification precision, select Use specified minimum and
maximum values for Input and Tunable parameters.
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• To verify the extreme cases of program execution, select Unbounded inputs
for Input and Use calibration data for Tunable parameters.
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Configuring Verification of Model Reference Code
From the Polyspace Model Link pane, you can specify the verification of
generated code with respect to model reference hierarchy levels:

• Model reference verification depth— From the drop-down list, select
one of the following:

- Current model only — Default. The software verifies code from the
top level only. The software creates stubs to represent code from lower
hierarchy levels.

- 1— The software verifies code from the top level and the next level. For
subsequent hierarchy levels, the software creates stubs.

- 2 — The software verifies code from the top level and the next two
hierarchy levels. For subsequent hierarchy levels, the software creates
stubs.

- 3 — The software verifies code from the top level and the next three
hierarchy levels. For subsequent hierarchy levels, the software creates
stubs.

- All — The software verifies code from the top level and all lower
hierarchy levels.

• Model by model verification — Select this check box if you want the
software to verify code from each model separately.

Note The same configuration settings apply to all referenced models within
a top model. It does not matter whether you open the Polyspace Model
Link pane from the top model window (Tools > Polyspace > Options) or
through the right-click context menu of a particular Model block within the
top model. However, you can run verifications for code generated from specific
Model blocks. See “Running Verification with Polyspace® Model Link™ SL
Software” on page 4-2.
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Specifying Location of Results
With Polyspace Model Link SL, you can specify a location for the results of
your verification:

1 From the Simulink model window, select Tools > Polyspace > Options.
The Configuration Parameters dialog box opens with the Polyspace Model
Link pane displayed.

2 In the Output folder field, specify the full path for your
results folder. By default, the software stores results in
C:\PolySpace_Results\results_model_name.

3 If you want to avoid overwriting results from previous verifications, select
the Make output folder name unique by adding a suffix check box.
Instead of overwriting an existing folder, the software specifies a new
location for the results folder by appending a unique number to the folder
name.
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Configuring Polyspace Verification Options
Polyspace Model Link software supports a simplified version of the Polyspace
Project Manager, which allows you to customize the options and project
properties for your verification. For example, you can specify the target
processor type, target operating system, and compilation flags.

To open the Configuration pane of the Project Manager:

1 From the Simulink model window, select Tools > Polyspace > Options.
The Polyspace Model Link pane opens.

2 Click Configure. The Project Manager opens, displaying
theConfiguration pane.

The first time you open the configuration, the software sets the following
options:
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• -OS-target — Set to no-predefined-OS

• -results-dir — Set to results

The software also configures other options automatically, but the settings
depend on the code generator used. See “Polyspace® Model Link™
SL Considerations” on page 3-21 and “Polyspace® Model Link™ TL
Considerations” on page 3-29.

3 Set other options as needed for your application.

For a list of recommended options for verifying generated code, see
“Recommended Polyspace Options for Verifying Generated Code” on page
3-23.

For descriptions of all verification options, see “Option Descriptions for C
Code” in the Polyspace Products for C/C++ Reference.
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Configuring Polyspace Project Properties
You can specify project properties, for example, your project name, through
the Polyspace Project - Properties dialog box. To open this dialog box,

1 From the Simulink model window, select Tools > Polyspace > Options.
The Polyspace Model Link pane opens.

2 Click Configure. The Project Manager opens.

3 On the Project Manager toolbar, click the Project properties icon .
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Creating a Polyspace Configuration File Template
During a batch run, you may want use different configurations for verification.
The software provides the command PolyspaceSetTemplateCFGFile, which
allows you to apply a configuration defined by a configuration file template.
See “MATLAB Functions For Polyspace Batch Runs” on page 4-14.

To create a configuration file template:

1 In the Simulink model window, select Tools > Polyspace > Options. The
Polyspace Model Link pane opens.

2 Click Configure. The Project Manager opens, displaying the
Configuration pane. Use this pane to customize the target and cross
compiler.

3 The Target processor type (-target) option defines the size of data types.
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a From the drop-down list in the Value column, select mcpu (Advanced).
The Generic target options dialog box opens.

Use this dialog box to create a new target and specify data types for the
target. Then click Save.

4 The Defined Preprocessor Macros (-D) option allows you to define
preprocessor macros for your cross-compiler. Click the ... button. The
Defined Preprocessor Macros dialog box opens.
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To add a macro, in the field under Defined Preprocessor Macros (-D)
enter the required text. Click the + button. The software adds your macro
to the displayed list.

To remove a macro, select the macro and click the - button.

Note If you use the LCC cross-compiler, then you must specify the
MATLAB_MEX_FILE macro.

When you have added or removed the required macros, click OK.

5 Save your changes and close the Project Manager.

6 Make a copy of the updated project configuration file, for example,
my_first_code_polyspace.cfg.

7 Rename the copy, for example, my_cross_compiler.cfg. This is your new
configuration file template.

To make a template the configuration for verification, run the
PolyspaceSetTemplateCFGFile command in the MATLAB Command
Window. For example:

PolyspaceSetTemplateCFGFile ('C:\Work\my_cross_compiler.cfg')
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Specifying Header Files for Target Compiler
If you want to verify code generated for a 16-bit target processor, you must
specify header files for your 16-bit compiler. The software automatically
identifies the compiler from the Simulink model. If the compiler is 16-bit and
you do not specify the necessary header files, the software produces an error
when you try to run a verification.

Note For a 32-bit or 64-bit target processor, the software automatically
specifies the default header file.

To specify header files (or folders containing header files) for your compiler:

1 Open the Polyspace Configuration pane. From the Simulink model
window, select Tools > Polyspace > Options. The Polyspace Model
Link pane opens.

2 Click Configure. The Project Manager opens, displaying the
Configuration pane.

3 On the Configuration pane, expand the Target/Compilation node.

4 To specify files, click the ... button for the Include (-include) option. The
Include dialog box opens. If you want to specify folders, click the… button
for the Include Folders (-I) option. In this case, the Include Folders
dialog box opens.

5 Specify a header file (or folder) path by doing one of the following:

• In the text field, enter the file (or folder) path and click +.

• Click the folder button and use the Select a file (or folder) to include
dialog box to navigate to the required header file (or folder).

The software displays the list of specified header files (or folders) in the
dialog window. You can remove a header file (or folder) from the displayed
list by selecting the file (or folder) and clicking -.
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Removing Polyspace Options From Simulink Model
You can remove Polyspace configuration information from your Simulink
model.

For a top model:

1 Select Tools > Polyspace > Remove Options from Current
Configuration.

2 Save the model.

For a Model block or subsystem:

1 Right-click the Model block or subsystem.

2 From the context menu, select Remove Options from Current
Configuration.

3 Save the model.
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Main Generation for Model Verification
When you run a verification using Polyspace Model Link SL, the software
automatically reads the following information from the model:

• initialize() functions

• terminate() functions

• step() functions

• List of parameter variables

• List of input variables

The software then uses this information to generate a main function that:

1 Initializes parameters using the Polyspace option -variables
written-before-loop.

2 Calls initialization functions using the option
-functions-called-before-loop.

3 Initializes inputs using the option -variables written-in-loop.

4 Calls the step function using the option -functions-called-in-loop.

5 Calls the terminate function using the option
-functions-called-after-loop.

If the codeInfo for the model does not contain the names of the inputs, the
software considers all variables as entries, except for parameters and outputs.

For more information on the main generator, see “Main Generator Behavior
for Polyspace Software”.

main for Generated Code

The following example shows the main generator options that the software
uses to generate the main function for code generated from a Simulink model.

init parameters \\ -variables-written-before-loop

init_fct() \\ -functions-called-before-loop
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while(1){ \\ start main loop

init inputs \\ -variables-written-in-loop

step_fct() \\ -functions-called-in-loop

}

terminate_fct() \\ -functions-called-after-loop
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Polyspace Model Link SL Considerations

In this section...

“Overview” on page 3-21

“Subsystems” on page 3-21

“Default Options” on page 3-21

“Data Range Specification” on page 3-22

“Recommended Polyspace Options for Verifying Generated Code” on page
3-23

“Hardware Mapping Between Simulink and Polyspace” on page 3-28

Overview
The Polyspace Model Link SL product has been tested with Embedded Coder
software. For more information, see the Polyspace Installation Guide.

Subsystems
A dialog will be presented after clicking on the Polyspace for Embedded Coder
block if multiple subsystems are present in a diagram. Simply select the
subsystem to analyze from the list. The subsystem list is generated from the
directory structure from the code that has been generated.

Default Options
When using the Polyspace Model Link SL product, the software sets the
following verification options by default:

-sources path_to_source_code
-desktop
-D PST_ERRNO
-D main=main_rtwec
-I matlabroot\polyspace\include
-I matlabroot\extern\include
-I matlabroot\rtw\c\libsrc
-I matlabroot\simulink\include
-I matlabroot\sys\lcc\include
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-OS-target no-predefined-OS
-results-dir results

Note matlabroot is the MATLAB installation folder.

Data Range Specification
You can constrain inputs, parameters, and outputs to lie within specified data
ranges. See “Configuring Data Range Settings” on page 3-6.

The software automatically creates a Polyspace Data Range Specification
(DRS) file using information from the MATLAB workspace and block
parameters.

You can also manually define a DRS file using the Project Manager
perspective of the Polyspace verification environment. If you define a DRS
file, the software appends the automatically generated information to the DRS
file you create. Manually defined DRS information overrides automatically
generated information for all variables.

The software supports the automatic generation of data range specifications
for the following kinds of generated code:

• Code from standalone models

• Code from configured function prototypes

• Reusable code

• Code generated from referenced models and submodels

The software supports the automatic generation of data range specifications
for only the following signal and parameter storage classes:

• SimulinkGlobal

• ExportedGlobal

• Struct (Custom)
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Recommended Polyspace Options for Verifying
Generated Code
The Polyspace Model Link SL software automatically specifies values for the
following verification options:

• -main-generator

• -functions-called-in-loop

• -functions-called-before-loop

• -functions-called-after-loop

• -variables-written-in-loop

• -variables-written-before-loop

In addition, for the option -server, the software uses the value specified
in the Send to Polyspace server check box on the Polyspace Model
Link pane. These values override the corresponding option values in the
Configuration pane of the Project Manager..

You can specify other verification options for your Polyspace Project through
the Polyspace Configuration pane. To open this pane:

1 In the Simulink model window, select Tools > Polyspace > Options .
The Polyspace Model Link pane opens.

2 Click Configure. The Project Manager opens, displaying the Polyspace
Configuration pane.

The following table describes options that you should specify in your Polyspace
project before verifying code generated by Embedded Coder software.
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Option Recommended Value Comments

Target/Compilation

-d See Comments Defines macro compiler flags used during
compilation.

Use one d for each line of the Embedded
Coder generated defines.txt file.

Polyspace Model Link SL does not do this
by default.

-OS-target Visual Specifies the operating system target for
Polyspace stubs.

This information allows the verification to
use appropriate system definitions during
preprocessing in order to analyze the
included files properly.

-target i386 Specifies the target processor type. This
allows the verification to consider the
size of fundamental data types and the
endianess of the target machine.

You can configure and specify generic
targets. For more information, see Setting
Up Project for Generic Target Processors
in the Polyspace Products for C User’s
Guide.

Compliance with standards
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Option Recommended Value Comments

-dos Selected You must select this option if the contents
of the include or source directory comes
from a DOS or Windows file system. The
option allows the verification to deal with
upper/lower case sensitivity and control
characters issues. Concerned files are:

• Header files – All include folders
specified (-I option)

• Source files – All source files selected
for the verification (-sources option)

-allow-negative-
operand-in-shift

Selected Allows a shift operation on a negative
number.According to the ANSI standard,
such a shift operation on a negative
number is illegal. For example, -2 << 2
If you select this option, Polyspace
considers the operation to be valid. For
the given example, -2 << 2 = -8

-misra2 [all-rules |
file_name]

Specifies that the software checks coding
rules in conformity to MISRA-C:2004. All
MISRA checks are included in the log file
of the verification. Options:

• all-rules – Checks all available
MISRA C® rules. Any violation of
MISRA C rules is considered a warning.

• filename – Specifies an ASCII file
containing a list of MISRA® rules to
check.

-includes-to-ignore <MSVC dir>\VC\include Specifies files or folders that are excluded
from MISRA rules checking (all files
and subfolders within the selected
folder). This option is useful when you
have non-MISRA C conforming include
headers.
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Option Recommended Value Comments

Polyspace inner settings

-ignore-float-
rounding

Selected Specifies how the verification rounds
floats.

If this option is not selected, the
verification rounds floats according to the
IEEE® 754 standard – simple precision
on 32-bits targets and double precision on
targets that define double as 64-bits.

When you select this option, the
verification performs exact computation.

Selecting this option can lead to results
that differ from "real life," depending on
the actual compiler and target. Some
paths may be reachable (or not reachable)
for the verification while they are not
reachable (or are reachable) for the actual
compiler and target.

However, this option reduces the number
of unproven checks caused by float
approximation.

Precision/Scaling

-O 2 Specifies the precision level for the
verification.

Higher precision levels provide higher
selectivity at the expense of longer
verification time.

Begin with the lowest precision level.
You can then address red errors and
gray code before rerunning the Polyspace
verification using higher precision levels.

Benefits:

A higher precision level contributes to a
higher selectivity rate, making results
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Option Recommended Value Comments

review more efficient and hence making
bugs in the code easier to isolate.

The precision level specifies the algorithms
used to model the program state space
during verification:

• -O0 corresponds to static interval
verification.

• -O1 corresponds to complex polyhedron
model of domain values.

• -O2 corresponds to more complex
algorithms to closely model domain
values (a mixed approach with integer
lattices and complex polyhedrons).

• -O3 is suitable only for units smaller
than 1,000 lines of code. For such code,
selectivity may reach as high as 98%,
but verification may take up to an hour
per 1,000 lines of code.

-to c-compile – When
checking MISRA
compliance only.pass0
– When verifying code for
the first time.

pass4 – When performing
subsequent verifications
of code.

Specifies the phase after which the
verification stops. Each verification phase
improves the selectivity of your results,
but increases the overall verification time.

Improved selectivity can make results
review more efficient, and hence make
bugs in the code easier to isolate.

Begin by running -to pass0 (Software
Safety Analysis level 0) You can then
address red errors and gray code before
relaunching verification using higher
integration levels.
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Hardware Mapping Between Simulink and Polyspace
The software automatically imports target word lengths and byte ordering
(endianess) from Simulink model hardware configuration settings. The
software maps Device vendor and Device type settings on the Simulink
Configuration Parameters > Hardware Implementation pane to
Target processor type settings on the Polyspace Configuration pane.

Note The software creates a generic target for the verification.
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Polyspace Model Link TL Considerations

In this section...

“Overview” on page 3-29

“Subsystems” on page 3-29

“Default Options” on page 3-29

“Data Range Specification” on page 3-30

“Lookup Tables” on page 3-30

“Code Generation Options” on page 3-31

Overview
The Polyspace Model Link TL product has been tested with the some release
of the dSPACE Data Dictionary version and TargetLink Code Generator - see
the Installation Guide for more information.

As the Polyspace Model Link TL product extracts information from the
dSPACE Data Dictionary remember to regenerate the code before performing
a Polyspace verification. This ensures that the Data Dictionary has been
correctly updated.

Subsystems
A dialog will be presented after clicking on the Polyspace for TargetLink
block if multiple subsystems are present in a diagram. Simply select the
subsystem to analyze from the list.

Default Options
The following default options are set by the tool:

-I path to source code
-desktop
-D PST_ERRNO
-I dspaceroot\matlab\TL\SimFiles\Generic
-I dspaceroot\matlab\TL\srcfiles\Generic
-I dspaceroot/matlab\TL\srcfiles\i86\LCC
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-I matlabroot\polyspace\include
-I matlabroot\extern\include
-I matlabroot\rtw\c\libsrc
-I matlabroot\simulink\include
-I matlabroot\sys\lcc\include

Note dspaceroot and matlabroot are the dSPACE and MATLAB tool
installation directories respectively.

Data Range Specification
The tool automatically creates Polyspace Data RangeSpecification (DRS)
information using the dSPACE Data Dictionary for each global variable. This
DRS information is used to initialize each global variable to the range of valid
values as defined by the min-max information in the data dictionary. This
allows Polyspace software to model every value that is legal for the system
during its verification. Further the Boolean types are modeled having a
minimum value of 0 and a maximum of 1. Defining the min-max information
carefully in the model can help Polyspace verification to be more precise
significantly because only range of reels values are analyzed.

You can also manually define a DRS file using the Project Manager
perspective of the Polyspace Verification Environment. If you define a DRS
file, the software appends the automatically generated information to the DRS
file you create. Manually defined DRS information overrides automatically
generated information for all variables.

DRS cannot be applied to static variables. Therefore, the compilation flags -D
static= is set automatically. It has the effect of removing the static keyword
from the code. If you have a problem with name clashes in the global name
space you may need to either rename one of or variables or disable this option
in Polyspace configuration.

Lookup Tables
The tool by default provides stubs for the lookup table functions. This
behavior can be disabled from the Polyspace menu. The dSPACE data
dictionary is used to define the range of their return values. Note that a
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lookup table that uses extrapolation will return full range for the type of
variable that it returns.

Code Generation Options
From the TargetLink Main Dialog, it is recommended to set the option Clean
code and deselect the option Enable sections/pragmas/inline/ISR/user
attributes.

When installing the Polyspace Model Link TL product, the tlcgOptions
variable has been updated with 'PolyspaceSupport', 'on' (see variable in
'C:\dSPACE\Matlab\Tl\config\codegen\tl_pre_codegen_hook.m' file).
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• “Running Verification with Polyspace® Model Link™ SL Software” on
page 4-2

• “Running Verification with Polyspace® Model Link™ TL Software” on
page 4-5

• “Monitoring Verification Progress” on page 4-7

• “Running a Verification from the Command Window” on page 4-8

• “Code Generation and Verification with a Configured Model” on page 4-12

• “MATLAB Functions For Polyspace Batch Runs” on page 4-14

• “Archive Files for Polyspace Verification” on page 4-15
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Running Verification with Polyspace Model Link SL
Software

To start a Polyspace verification of:

• Code generated from the top model, from the Simulink model window,
select Tools > Polyspace > Polyspace for Embedded Coder > Verify
Generated Code.

• All model reference code associated with the top model, from the model
window, select Tools > Polyspace > Polyspace for Embedded
Coder > Verify Generated Model Reference Code.

• Model reference code associated with a specific Model block or subsystem,
right-click the Model block or subsystem. From the context menu, select
Polyspace > Polyspace for Embedded Coder.

Note You can also start verification from the Polyspace Model Link pane
by clicking Run verification.

When the verification starts, messages appear in the MATLAB Command
window:

### Starting Polyspace verification for Embedded Coder

### Creating results folder C:\PolySpace_Results\results_my_first_code for system my_first_code

### Checking Polyspace Model-Link Configuration:

### Parameters used for code verification:

System : my_first_code

Results Folder : C:\PolySpace_Results\results_my_first_code

Additional Files : 0

Remote : 0

Model Reference Depth : Current model only

Model by Model : 0

DRS input mode : DesignMinMax

DRS parameter mode : None

DRS output mode : None
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### Writing DRS table in C:\PolySpace_Results\results_my_first_code\my_first_code_drs.txt

...

Polyspace verification of my_first_code project.

Starting at 11/04/2011, 12h35.

Follow the progress of the verification in the MATLAB Command window. If
you are running a server verification, you can follow the later stages of the
verification through the Polyspace spooler (Queue Manager).

The software writes all status messages to a log file in the results folder, for
example:Polyspace_R2012a_my_first_code_11_04_2011-17h26.log:

<polyspace-c R2012a PID6436 PGID6436>

Polyspace verification of my_first_code project.

Starting at 11/04/2011, 12h35.

Options used with Verifier:

-polyspace-version=CC-8.3.0.I5 (R2012a)

-author=auser

-from=scratch

-date=04/11/2011

-enum-type-definition=defined-by-standard

-lang=C

-allow-negative-operand-in-shift=true

-max-processes=4

-discard-asm=true

-variables-written-in-loop=custom=my_first_code_U

-results-dir=C:\PolySpace_Results\results_my_first_code

-target=mcpu

-scalar-overflows-behavior=truncate-on-error

-data-range-specifications=C:\PolySpace_Results\results_my_first_code\my_first_code_drs.txt

-functions-called-before-loop=[my_first_code_initialize]

-verif-version=1.0

-main-generator=true

-O=-O2

-variables-written-before-loop=none

-prog=my_first_code

-scalar-overflows-checks=signed

-D1=main=main_rtwec
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-D2=__restrict__=

-D3=MODEL=my_first_code

-D4=NUMST=1

-D5=NCSTATES=0

...

If you want to stop a client verification:

• From the Simulink model window, select Tools > Polyspace > Stop
Local Verification.

• Right-click a Model block or subsystem. From the context menu, select
Polyspace > Stop Local Verification.

If you want to stop a server verification, use the Polyspace Queue Manager
(Spooler). See “Stopping Server Verification Before It Completes”.
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Running Verification with Polyspace Model Link TL
Software

To start the Polyspace verification:

1 In the Simulink model window select Tools > Polyspace > Polyspace
for TargetLink.

The Configuration Parameters > Polyspace Model Link pane opens.

2 Click Run verification to start the verification.

Messages appear in the MATLAB Command window:

### Polyspace Model-Link for Embedded Coder
### Version MBD-5.7.0.6 (R2011a)
### Preparing code verification
### Creating results folder
### Analysing subsystem: my_first_code
### Locating generated source files:

H:\Documents\MATLAB\my_first_code_ert_rtw\ert_main.c ok
H:\Documents\MATLAB\my_first_code_ert_rtw\my_first_code.c ok

### Generating DRS table
my_first_code_U.In1 min max init
my_first_code_U.In2 min max init

### Computing code verification options
...

### Starting code verification

4-5



4 Run Code Verification

The exact messages depend on the code generator you use. However, the
messages always have the same format:

• Name of code generator

• Version number of the plug-in

• List of source files

• DRS (Data Range Specification) information.

Follow the progress of the verification in the MATLAB Command window. If
you are running a server verification, you can follow the later stages of the
verification through the Polyspace spooler (Queue Manager).

Note Verification of a 3,000 block model will take approximately one hour to
verify, or about 15 minutes for each 2,000 lines of generated code.
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Monitoring Verification Progress

In this section...

“Client Verifications” on page 4-7

“Server Verifications” on page 4-7

Client Verifications
For client verifications, you can follow the progress of the verification in the
MATLAB Command window. The software also saves all status messages to a
log file in the results folder. For example:

Polyspace_R2012a_my_first_code_11_04_2011-17h26.log

Server Verifications
For server verifications, you can follow the initial stages of the verification in
the MATLAB Command window. Once the compilation phase is complete,
you can follow the progress of the verification using the Polyspace Queue
Manager (Spooler).

To open the Polyspace Queue Manager, do one of the following:

• From the Simulink model window, select Tools > Polyspace > Open
Spooler.

• Right-click a Model block or subsystem. From the context menu, select
Polyspace > Open Spooler.

For more information, see “Managing Verification Jobs Using the Polyspace
Queue Manager” in the Polyspace Products for C/C++ User’s Guide.
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Running a Verification from the Command Window
The software supports the commands pslinkrun and pslinkoptions, which
allow you to run verifications from the MATLAB Command Window.

Use pslinkrun to run a verification:

• resultsFolder = pslinkrun runs a verification on the code generated
from the current system, that is, the system that the command bdroot
returns. The verification uses the configuration options associated with the
current system. resultsFolder gives the location of the results folder.

• resultsFolder = pslinkrun(system) runs a Polyspace verification on
the code generated from the model or subsystem system. The verification
uses the configuration options associated with system. resultsFolder
gives the location of the results folder.

For example:

>> resultsFolder1 = pslinkrun('psdemo_model_link_sl');

### Starting Polyspace verification for Embedded Coder

### Creating results folder C:\PolySpace_Results\results_psdemo_model_link_sl

for system psdemo_model_link_sl

...

• resultsFolder = pslinkrun(system, opts) runs a Polyspace verification
on the code generated from system. The verification uses configuration
options specified in the Polyspace Model Link options object opts. If opts
is empty, the verification uses the configuration options associated with the
model system. resultsFolder gives the location of the results folder.

• resultsFolder = pslinkrun(system, opts, topMdlRef) runs a
verification on the code generated from system. The verification uses
configuration options specified in the Polyspace Model Link options object
opts. If opts is empty, the verification uses the configuration options
associated with the model system.

If topMdlRef is false (default), the software verifies all code generated
from the top model. If topMdlRef is true, the software verifies only code
generated from models referenced by the top model.

resultsFolder gives the location of the results folder.
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Use pslinkoptions to create a Polyspace Model Link options object.

opts = pslinkoptions(dg) creates a Polyspace Model Link options object
opts for the code generator cg, which must be either 'ec' for Embedded
Coder or 'tl' for TargetLink. opts contains default values for each option.

For example:

>> opts_new=pslinkoptions('ec')

opts_new =

ResultDir: [1x40 char]

AddSuffixToResultDir: 0

EnableAdditionalFileList: 0

AdditionalFileList: {0x1 cell}

SendToPolyspaceServer: 1

ModelRefVerifDepth: 'Current model only'

ModelRefByModelRefVerif: 0

InputRangeMode: 'DesignMinMax'

ParamRangeMode: 'None'

OutputRangeMode: 'None'

>>

You can change configuration options by modifying properties of this object.
For example, to specify client verification:

>> opts_new.SendToPolyspaceServer = 0;

>> opts_new

opts_new =

ResultDir: [1x40 char]

AddSuffixToResultDir: 0

EnableAdditionalFileList: 0

AdditionalFileList: {0x1 cell}

SendToPolyspaceServer: 0

ModelRefVerifDepth: 'Current model only'

ModelRefByModelRefVerif: 0

InputRangeMode: 'DesignMinMax'
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ParamRangeMode: 'None'

OutputRangeMode: 'None'

>>

The following table provides, for each configuration option, possible values
and a description. The value in curly brackets {} is the default.

Configuration
Option

Values Description

ResultDir {'C:\Polyspace_
Results\results_
$ModelName$'}

Specifies location of results
folder. Can be either an
absolute path or a path
relative to the current folder.

AddSuffixTo
ResultDir

{false} | true Modifies location of results
folder by appending a unique
number to the folder name
instead of overwriting an
existing folder.

EnableAdditional
FileList

{false} | true Specifies whether additional
files should be verified.
You can specify these
additional files through the
AdditionalFileList option

AdditionalFile
List

{0x1 cell} Lists additional files to verify.

SendToPolyspace
Server

false| {true} Selects client or server
verification.

ModelRefVerif
Depth

{'Current model
only' | '1' | '2' |
'3' | 'All'

Specifies verification of
generated code with respect
to model reference hierarchy
levels. Applies only to
Polyspace Model Link SL.
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Configuration
Option

Values Description

ModelRefByModel
RefVerif

{false} | true Specifies whether to verify
code from models within
model reference hierarchies
jointly or separately. Applies
only to Polyspace Model Link
SL.

InputRangeMode {'DesignMinMax'} |
'FullRange'

Specifies whether to use data
ranges defined in blocks and
workspace or treat inputs as
full-range values. Applies
only to Polyspace Model Link
SL.

ParamRangeMode {'None'} |
'DesignMinMax'

Specifies whether to
use constant values of
parameters specified in code
or range defined in blocks
and workspace. Applies only
to Polyspace Model Link SL.

OutputRangeMode {'None'}|
'DesignMinMax'

Specifies whether to apply
assertions to outputs (using
range defined in blocks and
workspace). Applies only to
Polyspace Model Link SL.

AutoStubLUT {false} | true Specifies whether to include
Lookup Tables code in the
verification. Applies only to
Polyspace Model Link TL.

For information about other Polyspace Model Link commands, see “MATLAB
Functions For Polyspace Batch Runs” on page 4-14.
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Code Generation and Verification with a Configured Model
You can generate Embedded Coder code from the configured model
psdemo_model_link_sl and run a Polyspace verification on the generated
code.

To open psdemo_model_link_sl in the Simulink model window:

1 From
Polyspace_Common\PolySpaceModelLink\psdemos\psdemo_model_link_sl,
copy psdemo_model_link_sl.mdl to your working folder.

2 In the MATLAB Command Window, enter psdemo_model_link_sl.

To generate code and start the Polyspace verification:

1 Double-click the Re-install the demo block to generate the legacy code
related to the S-function.

2 If you want to apply data ranges to the input parameters, double-click the
green block Use input constraints. To remove the data range constraints,
double-click the orange block Worst case inputs.

3 Right-click the subsystem controller.

4 From the context-menu, select Code Generation > Build Subsystem.
The Build code for Subsystem dialog box opens.

5 Click Build to generate code. The code generation report opens when code
generation is complete.

6 Server verification is specified by default. If you want to specify
client verification, select Tools > Polyspace > Options. When the
Configuration Parameters > Polyspace Model Link pane opens, clear
the Send to Polyspace server check box. Then click OK.

7 Right-click the subsystem controller. From the context menu, select
Polyspace > Polyspace for Embedded Coder. The verification starts.

To monitor the progress of the verification:
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• If server verification is specified, select Tools > Polyspace > Open
Spooler. Use the Polyspace Queue Manager (Spooler) to monitor progress.

• If you specified client verification, you can monitor progress from the
Command Window.

Once the verification is complete, to display results:

1 Select Tools > Polyspace > Open Results > For Generated Code. The
Polyspace verification environment opens.

2 In the Polyspace verification environment, select File > Open Result. The
Open Results dialog box appears.

3 Use the Open Results dialog box to navigate to the specified results folder,
for example, C:\PolySpace_Results\controller.

4 Select the results file, for example,
RTE_px_controller_LAST_RESULTS.rte. Then click Open. The software
displays results in the Results Manager perspective.
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MATLAB Functions For Polyspace Batch Runs
In addition to pslinkrun and pslinkoptions, you can run the following
commands in the Command Window.

Command Description

PolyspaceForEmbeddedCoder Start Polyspace verification of code generated by Embedded
Coder.This command will be removed in a future release.
Use pslinkrun and pslinkoptions instead.

PolyspaceForTargetLink Start Polyspace verification of code generated by
TargetLinkThis command will be removed in a future
release. Use pslinkrun and pslinkoptions instead.

PolyspaceSpooler Open the Polyspace Queue Manager (Spooler), which allows
you to manage server verifications.

PolyspaceViewer Open Polyspace verification environment Results Manager
perspective.

PolyspaceSetTemplateCFGFile Select a template file, for example, during a batch run.

PolyspaceGetTemplateCFGFile Get the currently selected template file (empty by default).

PolyspaceReconfigure In case of a Polyspace release update without enabling the
MATLAB plug-in.

PolyspaceAnnotation Annotate block in Simulink model, which then appears in
Polyspace results. You can annotate either run-time checks
or coding rule violations, and provide a classification,
status, and comment for each annotation.

ver Display version numbers of MathWorks® products,
including Polyspace Model Link products.

4-14



Archive Files for Polyspace Verification

Archive Files for Polyspace Verification

In this section...

“Template File in MATLAB Installation folder\polyspace\” on page
4-15

“Files Used in Model Folder” on page 4-15

“Auto-Generated Files in Model Folder” on page 4-16

Template File in MATLAB Installation
folder\polyspace\
When a verification is first performed, the software creates a copy of
the file cfg\templateEmbeddedCoder.cfg in the local model folder,
model_folder\model_name-polyspace.cfg. The software does not create
a copy in subsequent verifications.

The file cfg\templateEmbeddedCoder.cfg contains the template Polyspace
configuration settings to support the TargetLink code generator. The
templateTargetLink.cfg file can be updated with site specific settings, to
facilitate verification of new models.

You can use the MATLAB command
PolyspaceSetTemplateCFGFile(config_filename) to change the name and
location of the file that contains the template configuration. For example,
when you run Polyspace verification as part of an automated process, which
specifies the template configuration file, erases the local copy in the model
folder, and starts the verification.

Files Used in Model Folder

• model-name-polyspace.cfg — As mentioned
above this file is copied from the MATLAB
installation_folder\polyspace\cfg\templateEmbeddedCoder.cfg file
the first time a verification is run on a model. It is subsequently modified
by the Project Configuration block, or the Configure button in the option
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in the Polyspace Analyzer dialog. It contains the Polyspace settings for
verifying the current model.

• polyspace_additional_file_list.txt — This file is created if the
Advanced option, Select Files is used in the Polyspace Analyzer dialog
box. This option allows files that are not part of the model to be analyzed
together with the model. For example these files could contain custom
lookup table code, custom stubs, device driver code etc. The Enable
additional file list option needs to be set together with configuring the
list of extra files to analyze.

Auto-Generated Files in Model Folder
These files are generated from the model for each verification when it is
started, and do not need archiving:

• model name_drs.txt — The DRS information extracted automatically
from the model.

• polyspace_include_dir_list.txt — List of compilation include
directories extracted from the mode.

• polyspace_file_list.txt— List of file contained in the model to analyze

• model name_last_parameter.txt — The last set of parameters used in
the Polyspace Analyzer dialog box.
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Viewing Results in Polyspace Verification Environment
When a verification completes, you can view the results using the Results
Manager perspective of the Polyspace verification environment.

Note If you perform a server verification, you must download your results
from the server before you can view them. For more information, see
“Downloading Results from Server to Client” in the Polyspace Products for
C/C++ User’s Guide.

To view your results:

1 From the Simulink model window, select Tools > Polyspace > Open
Results.

Note If you setModel reference verification depth to All and selected
Model by model verification, the Select the Result Folder to Open
in Polyspace dialog box opens. The dialog box displays a hierarchy of
referenced models from which the software generates code. To view the
verification results for code generated from a specific model, select the
model from the hierarchy. Then click OK.

You can also open results through a Model block or subsystem. From the
Simulink model window, right-click the Model block or subsystem, and
from the context menu, select Polyspace > Open Results.

After a few seconds, the Results Manager perspective of the Polyspace
verification environment opens.
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2

3 On the Results Summary tab, click any check to review additional
information.

In this example, the Check Details pane shows information about the
orange check, and the Source pane shows the source code containing the
orange check.
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For more information on reviewing run-time checks, see “Reviewing
Verification Results” in the Polyspace Products for C/C++ User’s Guide.

For information on specific checks, see “Colored Source Code for C” in the
Polyspace Products for C/C++ Reference.
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Identifying Errors in Simulink Models
Polyspace Model Link products allow you to trace run-time checks in your
verification results directly to your Simulink model.

Consider the following example, where the Check Details pane shows
information about an orange check, and the Source pane shows the source
code containing the orange check.

This orange check shows a potential overflow issue when multiplying the
signals from the inports In1 and In2. To fix this issue, you must return to
the model.

To trace this run-time check to the model:
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1 Click the blue underlined link (<Root>/Product) immediately before the
check in the Source pane.

The Simulink model opens, highlighting the block with the error.

2 Examine the model to find the cause of the check.

In this example, the highlighted block multiplies two full-range signals,
which could result in an overflow. This could be a flaw in either:

• Design — If the model is supposed to be robust for the full signal range,
then the issue is a design flaw. In this case, you must change the model
to accommodate the full signal range. For example, you could saturate
the output of the previous block, or bound the signal with a Switch block.

• Specifications — If the model is supposed to work for specific input
ranges, you can provide these ranges using block parameters or the base
workspace. The verification will then read these ranges from the model.
See “Specifying Signal Ranges” on page 2-9.

Applying either solution should address the issue and cause the orange
check to turn green.
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If your operating system is Windows Vista™ or Windows® 7, you may
encounter problems with the trace-back functionality if one of the following
conditions apply:

• User Account Control (UAC) is enabled.

• You do not have administrator privileges.

If you have a MATLAB session running and your model is open, a possible
workaround is:

1 Open a DOS window in administrator mode.

2 Go to your MATLAB installation folder.

3 From the bin folder, enter matlab -regserver.

4 Click the link again.
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